Can't see Zephyr Essential page content after the install

Incident Report for Zephyr Squad

Resolved

We found the issue and provided a fix.
Please wait for 30 seconds and reload the full page after installing the plugin.
Posted Jul 03, 2025 - 15:30 UTC

Investigating

We are currently investigating this issue.
Posted Jul 03, 2025 - 12:05 UTC
This incident affected: Zephyr Essential Cloud.